Get in touch
Back
Maintenance

Divi Cloud Critical Maintenance

Completed 16 Aug at 10:50am PDT.

Divi Cloud / Premade Layouts
Completed

Maintenance has been completed. Service availability is back to 100%.

Posted 16 Aug at 10:50am PDT.
Started

Divi Cloud is undergoing critical maintenance. During this time some users might be unable to access Divi Cloud. However, service should remain available for most users.

Posted 16 Aug at 10:06am PDT.