Get in touch
Back
Degraded

Divi Cloud Degraded Service

Started 14 Dec at 10:20am PST, resolved 14 Dec at 12:05pm PST.

Divi Cloud / Premade Layouts
Resolved

Service has been restored.

Posted 14 Dec at 12:05pm PST.
Created

Some requests to Divi Cloud are currently failing. We are working to restore service as quickly as possible.

Posted 14 Dec at 10:20am PST.